跳转到主内容
Waters China

加载 NuGenesis WebVision 客户端后,延迟两分钟后出现错误信息:HTTP 502.3 "Bad Gateway"(错误的网关)- WKB31372

故障描述

  • NuGenesis WebVision 站点加载速度非常慢
  • 打开项目视图时,浏览器显示错误信息:HTTP 502.3 "Bad Gateway"(错误的网关)
  • 在 Microsoft IIS 日志文件中,WebVision 站点的日志中至少有一个客户端请求记录了错误代码 502.3 和 12002,并且请求的时间值大约为 120000(120 秒)。
  • Apache Tomcat 日志文件中未记录任何错误信息,并且 Apache Tomcat 6 服务正在运行。

环境

  • NuGenesis 9 SDMS
    • Windows Server 2016/2019 中的 Microsoft IIS
    • Apache Tomcat v9.x
  • NuGenesis 8 SDMS
    • Windows Server 2012 中的 Microsoft IIS
    • Apache Tomcat 6.0.29

原因

代码 502.3 和 12002 表示 IIS 在等待来自代理服务器 (Apache Tomcat) 的响应时超时。缺省情况下,超时时间限为 120 秒。发生超时可能是由于 Apache Tomcat 服务出错、服务器性能下降(参见在 NuGenesis SDMS 中调试日志记录)或者 NuGenesis 的 Oracle 数据库性能下降/无响应。

解决方法

  1. 检查 NuGenesis SDMS Web 服务器上的 Apache Tomcat 6 服务的状态;其状态必须是“已启动”或“正在运行”。  重新启动 Tomcat 服务
  2. 在 Tomcat 日志文件中 (Drive:\Program Files (x86)\apache-tomcat-6.0.29\logs) 查找最近的错误信息。
  3. 禁用调试日志记录并重新启动服务:
    1. 打开 regedit 并查找 SDMS 调试的注册表项:
      • NuGenesis 8:HKLM\Software\Wow6432Node\NuGenesis Technologies Corp.\NuGenesis\8.0\Debug
      • NuGenesis 9:HKLM\Software\Wow6432Node\NuGenesis Technologies Corp.\NuGenesis\Debug
    2. 删除 Debug(调试)注册表项(如果存在)
    3. 关闭注册表
    4. 打开服务控制面板:“开始”>“运行”> services.msc
    5. 停止 Apache Tomcat 和万维网发布服务
    6. 重新启动 NuGenesis VISION Server 服务
    7. 启动 Apache Tomcat 和万维网发布服务
    8. 重新启动 NuGenesis RPC 服务
    9. 删除调试日志记录以释放服务器磁盘上的空间:
    10. 删除 Apache Tomcat 日志文件:
      • 驱动器:\Program Files (x86)\Waters\apache-tomcat-x.y.z\logs
  4. 重新启动 Internet Explorer 并重新登录 Web Vision
  5. 登录 SDMS Administrator 并验证“主”和“本地”列表中的所有数据库都在线且可访问。如果一个或多个数据库无法访问(即 SDMS Admin 在登录数据库时变得无响应),则数据库可能已关闭,需要重新启动
  6. 如果 NuGenesis Oracle 数据库在线/可访问,但是运行缓慢(通常是因为 SGA 空间不足或索引不足),这会导致超时和 HTTP 502 错误。有关数据库性能问题故障排除的工具和帮助,请联系 Waters 技术支持

附加信息

如果 NuGenesis 8 Web 服务器上的 Java Runtime Environment 更新到 Java 1.7 Update 2 之后,也可能发生 HTTP 502.3 错误。新版本 JRE 与 Apache Tomcat 不兼容,并阻止其响应 IIS,导致 IIS 在浏览器中显示 502.3 错误代码。请根据链接文章中的说明进行 NuGenesis 9 SDMS Web 服务器的 Java 升级。

id31372, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG