跳转到主内容
Waters China

使用 NuGenesis LMS Toolbox 时出现错误:Failed to connect to Oracle database - WKB29852

故障描述

  • 通过 NuGenesis LMS Toolbox 导出或导入数据时,出现以下消息:
    • “Failed to connect to the Oracle database”(无法连接到 Oracle 数据库)
  • 在 Toolbox 界面中选择的 Oracle Service 有效,数据库本身正在运行

环境

  • NuGenesis 8 LMS
  • NuGenesis 8 ELN

原因

  1. 已安装 Oracle 客户端(例如 NuGenesis 随附的 Waters Oracle 客户端),但客户端的 tnsnames.ora 中没有所选的服务名称。
  2. 在 Toolbox 中指定的 ELNPROD 用户密码不正确。

解决方法

  1. 验证 Oracle 客户端配置:
    1. 从“开始”菜单或“开始”界面运行 Waters 网络配置助手。
    2. 在 Toolbox 中选择的“Oracle Service”必须与客户端 tnsnames.ora 文件中的别名匹配。
      1. 示例:如果在 Toolbox 中选择了“SDMS8.WORLD”,则“配置助手”中必须有一个别名为“SDMS8”的条目
    3. 如果文件中不存在具有所选别名的条目,请在其中创建条目
      • 文件中通常会包含正确的数据库主机、服务名和端口号,但会使用不同名称。
      • 在这种情况下,请新建一行,指定正确的别名,然后复制现有条目中的主机名、服务名和端口号。
    4. 保存修改的配置。
  2. 为 ELNPROD 指定正确的密码。
    1. 工具箱中的 User(用户)列表显示了数据库中的 Oracle 帐户列表。Toolbox 只能使用“ELNPROD”。
    2. 在 Password(密码)框中输入 ELNPROD 的密码。
    3. 密码缺省为“elnprod”,但这不是 NuGenesis 8 中 ELNPROD 帐户的缺省密码。
    4. 单击 Next(下一步)按钮以验证与数据库的连接性。
  3. 如果与数据库的连接仍然失败,请查看 Toolbox 日志文件以了解详细信息。
    1. 缺省日志文件位置为 %TEMP%\Toolbox.log。
    2. 在 Toolbox 安装文件夹中的 ELNToolbox.exe.config 文件中查找日志文件的路径。

附加信息

Toolbox 会显示在 Toolbox 中通过 Set Preferences(设置首选项)菜单所配置的配置文件的 Oracle Service 列表。此路径通常是 NuGenesis Oracle 服务器的 Oracle Home(主页)路径,或者至少是完整的 Oracle 11g 客户端主目录。当 Toolbox 尝试连接到数据库进行导出或导入时,它会通过 TNS_ADMIN 系统变量进行连接。此变量通常指向与 Toolbox 中配置的 Oracle Home(主页)不同的 Oracle 客户端安装(例如适用于 NuGenesis 的 Waters Oracle 客户端)。确保所有 Oracle 客户端中的 tnsnames.ora 和 sqlnet.ora 文件具有相同的 NuGenesis 数据库连接信息。

id29852, NGLMS, NGLMSLIC, NGLMSOPT, SUPNG