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使用 NuGenesis SDMS SDK 通过 LDAP/TLS 登录 SDMS 时出现错误:[NG17538] Unable to create LDAP session(无法创建 LDAP 会话)- WKB209611

故障描述

  • 使用有效的 LDAP 凭据登录时,SDMS SDK 会返回以下错误消息:
    • [NG17538] Unable to create LDAP session(无法创建 LDAP 会话)

环境

  • NuGenesis 9 SDMS
  • 在 SDMS 中启用 TLS,进行 LDAP 验证

原因

SDK 应用程序无权访问 NuGenesis SDMS 安装文件夹中的 CACerts.cer 文件;或者,用户有权访问该文件夹,但 SDK 应用程序会同时处理用户会话。在后一种情况下,用户会话在访问 CACerts.cer 时发生冲突,导致频繁出现 NG17538 错误。

解决方法

  1. 对于单用户的 SDK 应用程序(即,应用程序不会一次处理多个用户会话):将驱动器:\Program Files (x86)\Waters\NGSDMS\Common Files 上的“修改”访问权限授予认证用户组。
  2. 对于多用户的 SDK 应用程序,可行的解决方法是避免在应用程序中使用 LDAP 帐户。在数据库中为每个需要访问 SDK 应用程序的用户创建 Oracle 帐户(Oracle 用户名必须与 LDAP 用户名不同)。在 SDMS 管理员或 SDMS Help Desk Web 应用程序中将 Oracle 用户名分配给匹配的 SDMS 用户帐户。

附加信息

已针对此问题创建改进请求报告 CRI-3909。

id209611, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG