使用 NuGenesis Transfer App 时出现错误信息:[NG14647] Failed to connect to the server([NG14647] 无法连接服务器)- WKB19784
文章编号: 19784点击此处访问英文版本文章
故障描述
- 从 NuGenesis 中打开报告或下载文件数据时,Transfer Application(传输应用程序)显示以下错误信息:
- [NG14647] Failed to connect to the server.([NG14647] 无法连接服务器。)
环境
- NuGenesis 8 SDMS
- NuGenesis 9 SDMS
原因
用户的计算机无法连接到 NuGenesis SDMS 服务器上的 NuGenesis RPC 服务。
解决方法
- 确保服务器上已启动 NuGenesis RPC service。
- 通过 NuGenesis 服务器上的防火墙关闭或允许 TCP 端口 2500-2504 上的流量通过。
- Transfer 应用程序将使用 NuGenesis Web 服务器上 WebVision 配置文件中的设置作为 NuGenesis RPC 服务的主机和端口号
- NuGenesis 8 和 9(旧版 WebVision):
- NuGenesis 8:驱动器:\Program Files (x86)\apache-tomcat-6.0.29\webapps\WebVision\ngvision\WebVision.ini
- NuGenesis 9:驱动器:\Program Files (x86)\Waters\apache-tomcat-9.0.8\webapps\WebVision\ngvision\WebVision.ini
- RPC 服务的主机名和端口号将作为 WebVision.ini 中服务器列表上的 2 个“local”条目参数,显示在最右侧
- 例如:local='localhost,1,12020,...,'NuGenesis RPC Service V8.0','NG8ProdServer',2500 (NuGenesis 8 SDMS)
- 例如:local='localhost,1,12020,...,'NuGenesis RPC Service','NG8ProdServer',2500 (NuGenesis 9 SDMS)
- NuGenesis 9(新版 WebVision)
- 驱动器:\Program Files (x86)\Waters\NGSDMS\Application Server\Vision\SdmsProjects\appsettings.json
- NuGenesis RPC 服务的主机名和端口在文件的“RpcService”模块中给出
- 如果对 WebVision 配置文件进行了更改,请打开 IIS 管理器并重新启动旧版 WebVision 的缺省网站和新 WebVision(新版 WebVision)的 SdmsProjects
- NuGenesis 8 和 9(旧版 WebVision):
- 确保客户端计算机可以解析 RPC 服务的主机名:
- 在客户端计算机上的 hosts 文件中添加将 RPC 服务名称映射到服务器 IP 地址的条目。
- 或者,更改 WebVision.ini 中的条目,使用完全限定的域名。
- 或者,与本地的 IT 专家合作,确保授权 DNS 服务器的主机名记录具有正确的 NuGenesis 服务器 IP 地址。
- 在客户端计算机上,使用 Ping 和 NSLookup 工具测试与 NuGenesis 服务器的连接。
附加信息
对于 NuGenesis 9 SDMS,系统显示 [NG14647] Failed to connect to the server([NG14647] 无法连接至服务器)之前会显示一个消息框,提示 The password you used to log in will expire in <nnnnnn> days. Would you like to change it now?(您用于登录的密码将在 <nnnnnn> 天内过期,是否要立即更改?)。
id19784, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG