无法登录 NuGenesis LMS-SDMS Interface 向导 - WKB18325
文章编号: 18325点击此处访问英文版本文章
故障描述
- 登录 SDMS Extract Results Wizard(提取结果向导)时出现以下错误信息:
- Login to LMS Failed: Please check connectstring and credentials.(登录 LMS 失败:请检查连接字符串和凭据。)
环境
- NuGenesis 9 LMS
- NuGenesis 8 LMS
- NuGenesis 8 ELN
原因
- SDMS2ELN.ini 文件中的登录凭据或连接网址无效
- LMS-SDMS Interface 与 LMS SDK 的版本不同
解决方法
- 运行 LMS SDK 和 LMS-SDMS Interface 的 Auto IQ 程序。
- 比较 IQ 日志文件中的次要版本号。
- 可行示例:NuGenesis LMS SDK 9.0.2 Service Release 和 NuGenesis LMS SDMS Interface V2.0.2
- 不可行示例:NuGenesis LMS SDK 9.0.2 Service Release 和 NuGenesis LMS SDMS Interface V2.0
- 如果次要版本不匹配,请从安装媒体中安装正确版本的 LMS-SDMS Interface。
- 配置:
- 停止 NuGenesis LMS SDMS Interface 服务。
- 编辑 C:\ProgramData\Waters\Sdms Result Extractor 中的文件 SDMS2ELN.ini。
- 将 ELNUser 和 ELNPasswd 设置为有效的 LMS 用户名和密码。
- 确认 ELNConnect 字符串包含正确的 LMS 服务器主机名或完全限定的名称,端口号 8180 和“/vp/services/”。
- 保存并关闭文件。
- 启动服务。
- 确认 LMS 服务器上的 NuGenesis LMS Server 服务已启动;确认用户可以登录 LMS。
附加信息
如果在配置 LMS 用于 LDAP 验证的情况下使用 SYSTEM 帐户配置服务,则服务日志文件中会出现以下消息:
"DATE TIME,942 [6] ERROR Waters.ELN.ToolKit.SessionContext [(null)] - logon failed with reason 4"(登录失败,原因为 4)
id18325, NGLMS, NGLMSLIC, NGLMSOPT, password, SUPNG