跳转到主内容
Waters China

在已经安装 NuGenesis 传输应用程序的情况下仍提示安装 - WKB967

故障描述

  • 尝试预览报告或从 WebVision 下载文件时,提示用户安装 NuGenesis 传输应用程序,但该传输应用程序已经安装在他们的 PC 上。

环境

  • NuGenesis 9 SDMS
  • NuGenesis 8 SDMS
  • Internet Explorer 8 到 11
  • Microsoft Edge 中的 IE 模式

原因

NuGenesis 传输应用程序未在 Windows 中正确注册。具体而言,Internet Explorer 浏览器在向 NuGenesis 网站服务器发送 HTTP 请求时,其 Accept 头中不包含“application/nugenesis-sdms”。

解决方法

  1. 确认传输应用程序已安装;运行传输应用程序的 Auto IQ 并检查日志文件中的错误
  2. 将 WebVision 服务器添加到 IE 受信任的网站安全区和其兼容性视图列表。二者都需要正确操作 WebVision 网站
  3. 检查 64 位 IE(仅适用于 NuGenesis 8 SR1),缺省情况下,它与传输应用程序不兼容
  4. 在 PC 上运行 Register SDMS MIME Type 实用程序。关闭然后重新打开浏览器;如果此消息仍然存在,请重新启动客户端计算机。重新启动之前,请删除浏览器中的 cookie 和历史记录。该实用程序可以在“开始”菜单中找到:
    • NuGenesis 9:“开始”/“所有程序”/NuGenesis LMS SDMS/Register SDMS MIME Type
    • NuGenesis 8:“开始”/“所有程序”/NuGenesis 8.0/Register SDMS MIME Type
  5. 在注册表中搜索“Application/nugenesis-sdms”。如果搜索到这些值,请将其更改为“application/nugenesis-sdms”。
    • 尤其要查找以下所有注册表项:
      1. 32 位 IE 必须提供的系统缺省注册表项:
        • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Internet Settings\Accepted Documents
      2. 64 位 IE 必须提供的系统缺省注册表项:
        • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\Accepted Documents
      3. 用户特定的注册表项,位于 HKEY_USERS\[user SID]\Software\... 中。这些注册表项可能不存在于计算机上的所有帐户中,在这种情况下,系统缺省注册表项对这些没有这种注册表项的用户有效
  6. 重新启动客户端计算机
  7. 删除用户的配置文件。有时,Internet Explorer 会在 Accept 头中发送“Application/nugenesis-sdms”。这是由于用户的配置文件有误,清除客户端计算机(或 Citrix 服务器,如果他们使用 Citrix)上的配置文件是已知能修复此问题的方法。

附加信息

将客户端计算机升级到 Windows 10 版本 1909 或 20H2 后,在多个客户安装中已经看到此错误。

NuGenesis WebVision 服务器检查来自客户端的 HTTP 请求中字符串“application/nugenesis-sdms”的 Accept 头。每当用户选择要下载/预览的文件或报告时,它都会检查标题,比较区分大小写。如果出于任何原因 Accept 头中不包含该字符串,则 WebVision 将响应一个页面,提示用户下载传输应用程序;否则,服务器将响应 .NGX 文件,该文件由传输应用程序处理。

确认已安装更新的服务版本。

id967, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG