跳转到主内容
Waters China

无法登录 NuGenesis LMS;server.log 文件中出现 DEPLOYMENTS IN ERROR(部署出错) - WKB78521

故障描述

  • 用户在尝试登录 NuGenesis LMS 时收到错误信息:
  • NuGenesis LMS Server 服务已在错误消息中给出的 URL 中的计算机上启动
  • LMS 服务器的 log 文件中看不到以下错误消息:
    • 2019-10-07 22:01:57,672 ERROR [ProfileServiceBootstrap] (Thread-2) Failed to load profile:: org.jboss.deployers.client.spi.IncompleteDeploymentException: Summary of incomplete deployments(有关详细信息,请参阅之前的错误):

      DEPLOYMENTS IN ERROR(部署出错):
        Deployment "vfs:///D:/WatersELNServer/Jboss-6.0....ecurity-mx.sar" is in error due to the following reason(s): java.lang.NullPointerException
        Deployment "vfs:///D:/WatersELNServer/Jboss-6.0....deploy/eln.ear" is in error due to the following reason(s): javassist.NotFoundException: com.creon.common.security.LoginResult

环境

  • NuGenesis 9 LMS
  • NuGenesis 8 LMS
  • NuGenesis 8 ELN

原因

在 LMS 服务器中创建了无效的会话文件。此无效会话文件会阻止服务器启动和侦听端口 8180。

解决方法

  1. 转到 LMS 服务器中的 sessions 文件夹。
    • 示例:驱动器:\WatersLMSServer\Jboss-6.0.0.Final\SessionFiles
  2. 查找名为“-sessions.store”的文件。删除此文件或将其移出 SessionFiles 文件夹。
  3. 重新启动 LMS Server 服务。

附加信息

NG8 FR1 中已修复的软件缺陷 (D_300127_05323)

id78521, ELN, NGLMS, NGLMSLIC, NGLMSOPT, SUPNG