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NuGenesis RPC 服务正在运行,但 NGD 文件未被移出 TE_TEMP - WKB66330

故障描述

  • NuGenesis TE_TEMP 文件夹中存在 NGD 文件,但软件不处理此文件
  • NuGenesis RPC 服务正在运行
  • 在 Windows“任务管理器”中,NGRPCService.exe 进程正在运行,但列表中没有 NGRPCShadowServer.exe 进程
  • Transport Engine(传输引擎)无法启动

环境

  • NuGenesis 9 SDMS
  • NuGenesis 8 SDMS

原因

NuGenesis RPC 服务用户的 Temp 文件夹中有一个空的“TETime.ini”文件;或者,C: 盘中存在名为“%APPDATA%”的文件。

解决方法

  • 0 字节 NGTETime.ini 文件:
    1. 在 NuGenesis RPC 服务帐户的 Temp 文件夹中找到 TETime 文件。Temp 文件夹通常位于 C:\Windows\Temp 或 C:\Temp。如果服务使用指定用户帐户(本地帐户或域帐户)运行,则 INI 文件位于 C:\Users\username\AppData\Local\Temp。
    2. 删除 TETime 文件:
      • NuGenesis 9:NGTETime.ini
      • NuGenesis 8:NG80TETime.ini
    3. 重新启动 NuGenesis RPC 服务
    4. 已针对此问题提交缺陷报告 CRI-611。此问题已在 NuGenesis 9.0.2 中修复,但前提是新安装了 SDMS 软件;9.0.2 更新程序中不包括缺陷 CRI-611 的修复。可单独从 Waters 下载此修复程序,作为升级到 9.0.2 的系统的软件补丁。请联系 Waters 技术支持或您的现场服务工程师,获取此补丁的帮助
  • C:\ 盘中的文件:
    1. 在 C:\ 文件夹中查找名为 %APPDATA% 的文件。确保隐藏文件和系统文件在 Windows“资源管理器”中可见
    2. 如果找到这些文件,请将其删除

附加信息

如果文件存在但大小为 0 字节,NuGenesis RPC 服务将进入此状态。如果文件不存在,服务会生成一个新的 TETime 文件。已针对此问题创建缺陷报告 CRI-611。

另外,在某些情况下,重新启动数据库服务器可以解决此问题。

另一发现是,客户在 D:盘上创建了 TEMP 文件夹,最初在 C:Temp 文件夹结构中找到未该文件,但经过进一步查找,我们在其他驱动器上找到了另一个 TEMP 文件。如果使用上述目录不能立即解决问题,不妨查看其他驱动器。

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