登录 NuGenesis LMS 客户端时出现错误:LMS server is available(LMS 服务器不可用)- WKB48402
文章编号: 48402点击此处访问英文版本文章
故障描述
- 登录 NuGenesis LMS 时出现以下错误信息:
- LMS server is available(LMS 服务器不可用)
环境
- NuGenesis 9 LMS
- NuGenesis 8 LMS
- NuGenesis 8 ELN
原因
- NuGenesis LMS 的 Oracle 数据库已停止
- NuGenesis LMS 服务器服务已停止
- 客户端计算机无法解析 LMS 服务器的主机名或完全符合条件的计算机域名
如果所有 LMS 用户都收到此消息,则可能是 Oracle 或 LMS 服务器出现问题;(如果问题仅影响到一个或几个用户),则可能是其客户端计算机的问题。
解决方法
- 确保 Oracle 数据库在线且已打开。
- 查看 NuGenesis LMS/SDMS 实例的警报日志,查看最近是否出现可能导致实例无法启动的错误。
- 对于 Windows 上的 Oracle 数据库,确保服务 OracleServiceSDMS 和 OracleSDMSTNSListener 均已启动并已设置为自动启动。
- 启动或重新启动 NuGenesis LMS 服务器服务:
- 远程访问 LMS 服务器计算机,并确保已启动 NuGenesis LMS 服务器服务且将其设置为自动启动。
- 该服务可在出错状态下启动并保持运行;因此,请查看驱动器:\WatersLMSServer\log\server.log 中的日志文件中是否最近出现错误。
- 确定客户端计算机能否解析服务器的主机名或符合条件的域名:
- 远程访问 LMS 服务器并从桌面或“开始”界面运行 NuGenesis LMS IIS Configuration(NuGenesis LMS IIS 配置)工具。
- 单击配置工具中的 Next(下一步)。
- 在表格的 Server Host(服务器主机)列中记录条目。第一个条目通常是相同的服务器计算机,条目 1 和 2 通常是备用 LMS 服务器/环境,这些条目也可能不在表中。
- 打开命令提示符窗口并运行 ipconfig 工具以获取服务器的 IP 地址。
- 在客户端计算机上,打开命令提示符窗口,并使用 ping.exe 工具 ping LMS 服务器的主机名和完全符合条件的名称。
- 如果 ping 工具返回的 IP 地址与 ipconfig 工具输出的 IP 地址不同,则可能是 DNS 解算器返回了该名称的错误 IP 地址,或者 localhosts 文件中包含具有该名称的错误 IP 地址的条目。
- 在不同子网中的其他客户端上重复此测试。
- 编辑 LMS IIS Configuration(LMS IIS 配置)以使用主机名或完全符合条件的域名(两者均可在客户端计算机中更广泛地解析名称)。
- 确保 NuGenesis LMS 服务器上的 Windows 防火墙允许入站流量进入端口 8180。
- 如果 LMS 客户端仍然无法连接到服务器,请向网络管理员咨询任何可能禁止客户端计算机和服务器之间连接的网络级防火墙。
- 确保 module.xml 中没有无效的字体引用
- 在 LMS 服务器上,浏览至 <驱动器>:\WatersLMSServer\Wildfly-11.0.0.Final\modules\system\layers\base\waters\lms\reports\main(v8 中的路径不同)并打开 module.xml 文件。确保所有引用的字体文件都有效。删除或注释掉与不存在的字体文件对应的任何行,然后重新启动 NuGenesis LMS 服务器服务。
附加信息
id48402, ELN, NGLMS, NGLMSLIC, NGLMSOPT, SUPNG