无法从Agilent OpenLab CDS ChemStation 版本打印到 NuGenesis UNIFY - WKB29322
文章编号: 29322点击此处访问英文版本文章
故障描述
- 从 OpenLab CDS ChemStation 版打印至 UNIFY 时,打印作业无法完成
- 在 UNIFY 打印机队列中,打印作业的状态为 Spooling(正在假脱机),并且归(与登录 Windows 的用户帐户不同的)用户帐户所有
- Manual Mode(手动模式)打印不出现 UNIFY tag(UNIFY 标签)对话框
环境
- NuGenesis 8 SDMS
- Agilent OpenLab CDS ChemStation 版 C.01.0x
原因
OpenLab 软件将在与用户自己的会话不同的远程桌面会话中运行数据分析程序。根据设计,此单独的会话将使用与用户自己的登录 ID 不同的用户 ID;因此,打印作业所有者不是用户的 ID。在单独的会话中运行的 NG80prox.exe 进程将执行打印作业,并且在打印过程中显示的任何对话框(即使是在“批量模式”打印中)都将停止打印作业。这些对话框将显示在远程桌面会话中,但对用户不可见。
解决方法
- 登录 Windows,使用与 ChemStation 应用程序为数据分析应用程序创建远程桌面会话时所使用的帐户相同的帐户。这样,NG80prox.exe 进程将处理打印作业,并在用户自己的会话中显示任何必需的对话框。
- 如果上述解决方法不起作用,则无法使用 NuGenesis UNIFY 打印机从 OpenLab CDS ChemStation 捕获报告。
- 将来自 ChemStation 的报告在磁盘上以 PDF 文件的形式保存,并使用 NuGenesis File Capture 代理和提取模板存档 PDF 文件。
附加信息
id29322, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG, 安捷伦