在新安装的客户端上启动 Empower 时,即使客户端上有 TNSnames.ora 文件,也会出现错误:输入要连接的数据库的服务名称。
文章编号: 96089点击此处访问英文版本文章
故障描述
- 在新客户端上启动 Empower 时出现错误:
- 输入要连接的数据库的服务名称。如果未使用命名服务,则可能需要使用“网络配置助手”定义服务名称。
- 已将客户端上的 TNSnames.ora 文件从工作客户端复制到正确的文件位置(例如:C:\Empower\Oracle\Oracle19cclient\network\admin)
- TNSnames.ora 文件包含正确的数据库信息和服务名称
- 客户端的 TNS ping 成功
环境
- Empower 3 软件
- Empower 企业版
原因
客户端安装未读取 TNSnames.ora 文件。
解决方法
- 在 Empower 的登录窗口中键入数据库服务的名称
- 登录。
- 用户登录时,服务名称现在将列在下拉列表中
附加信息
如果 Empower 客户端计算机上设置了 TNS_ADMIN 环境变量,并且该变量指向错误的路径,则可能会出现此信息。缺省情况下,Empower 在安装时不使用“设置”此变量,但可以由其它 Oracle 客户端软件(如 NuGenesis Oracle 客户端)的安装程序用户进行设置。可以在 Windows 中将此系统环境变量设置为 Empower Oracle 客户端的主路径,然后 Empower 应该能够找到 tnsnames.ora。
id96089, EMP2LIC, EMP2OPT, EMP2SW, EMP3GC, EMP3LIC, EMP3OPT, EMP3SW, EMPGC, EMPGPC, EMPLIC, EMPOWER2, EMPOWER3, EMPSW, SUP