尝试通过客户端登录 Empower 时,用户会收到以下信息:ORA 12154: Could not resolve the connect identifier specified(ORA 12154:无法解析指定的连接标识符)- WKB24289
文章编号: 24289点击此处访问英文版本文章
故障描述
- 无法通过新安装的客户端登录 Empower
- 可以通过名称和 IP 地址从客户端 Ping 服务器
- 尝试通过客户端登录时出现 ORA 12154 错误
- 管理员可以通过服务器登录 Empower 而不会出现问题
环境
- Empower 3 企业版
- 客户端 PC
原因
以下目录中缺少 tnsnames.ora 文件:C:\Empower\Oracle\Oracle11gClient_2\network\admin
解决方法
从其它网络位置(如另一个客户端或 LAC/E32)复制 tnsnames.ora 文件,并将其粘贴到新客户端的 admin 文件夹中。
附加信息
id24289, EMP2LIC, EMP2OPT, EMP2SW, EMP3GC, EMP3LIC, EMP3OPT, EMP3SW, EMPGC, EMPGPC, EMPLIC, EMPOWER2, EMPOWER3, EMPSW, SUP